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Zeb-Revo + GeoSLAM Hub
The use of the Zeb-Revo and processing of Zeb-Revo data in GeoSLAM Hub is explained in detail in
the Zeb-Revo manuals provided by GeoSLAM. Some additions can however be made concerning the
application of this software in forestry and outside application. This section provides information on
possible GeoSLAM Hub installation issues and simplified step by step walkthroughs of both Zeb-Revo
systems.

Installation notes
The (black) USB stick that comes with the Zeb-Revo contains guides for the installation of the
GeoSLAM Hub and GeoSLAM Draw. Geoslam Draw is mostly used for inside environments and
applications. Considering the installation uses a virtual machine and requires specific processor
requirements some errors might occur that are not described in the available guides.
The first error that might occur is that the GeoSLAM Hub software cannot initialize the processing
engine via Oracle Virtual Box. This error will describe that there is something wrong with for example
the file destination of the virtual machine. In some cases, that can be due to the GeoSLAM installation
advising the installation of an outdated or incorrect version of Oracle Virtual Box (v5.1.22). If this error
occurs, first uninstall Virtual Box (v5.1.22) and install the most recent version of the v5.1 series
(v5.1.36). After installation restart your pc and GeoSLAM Hub should recognize the virtual machine
and this start the processing engine.
The second error that might occur is that your pc does not have hardware virtualization enable which is
necessary for GeoSLAM Hub. This setting has to be change in the BIOS settings as follows:
1. Reboot the computer and open the system's BIOS menu. This can usually be done by pressing
the Delete key, the F1 key or Alt and F4 keys depending on the system.
2. Select Restore Defaults or Restore Optimized Defaults, and then select Save & Exit.
3. Power off the machine and disconnect the power supply.
4. Enabling the virtualization extensions in BIOS
Note: BIOS steps
Many of the steps below may vary depending on your motherboard, processor type, chipset and OEM.
Refer to your system's accompanying documentation for the correct information on configuring your
system.
a. Power on the machine and open the BIOS (as per Step 1).
b. Open the Processor sub-menu The processor settings menu may be hidden in
the Chipset, Advanced CPU Configuration or Northbridge.
c. Enable Intel Virtualization Technology (also known as Intel VT) or AMDV depending on the brand of the processor. The virtualization extensions may be
labeled Virtualization Extensions, Vanderpool or various other names depending on
the OEM and system BIOS.
d. Enable Intel VTd or AMD IOMMU, if the options are available.
e. Select Save & Exit.
5. Power off the machine and disconnect the power supply.
6. Run cat /proc/cpuinfo | grep vmx svm. If the command outputs, the virtualization extensions
are now enabled. If there is no output your system may not have the virtualization extensions
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or the correct BIOS setting enabled. In some cases, the command is not recognized in which
case it is best to start GeoSLAM Hub and check if the error still occurs.
With these fixes the software should initialize correctly if the license dongle is inserted when requested
by GeoSLAM hub during the start-up of the processing engine.

Original Zeb-Revo
The original version of the Zeb-Revo uses a black box for data collection. This means that data is first
collected onto the hard drive of the black box and must then be copied to a computer. The data can then
be processed in GeoSLAM Hub. The process of data collection and processing for the original ZebRevo can be found in detail in the “ZEB-REVO User Guide V3.0.0”. The following explanation is a
short walkthrough of the steps necessary to successfully collect and process data, including a list of the
equipment available. For a quick start up GeoSLAM also provides a guide, namely: “ZEB-REVO –
Quickstart guide v1.1.1”

Measurement accessories













Bag
Data Logger
Battery for data logger (inside the frame of the data logger)
Handheld scanner (Zeb-Revo)
Cable which connects the handheld scanner and camera to the data logger
Cable which connects the data logger to an external data storage
USB stick
Dongle (for the GeoSLAM software license)
USB mini cable (to connect GoPro camera to the computer + charging (white))
Charger/Adapter for battery for data logger
GoPro camera attached to Zeb-Revo

In practice
Start-up:







Find a stable point where you can put the device on its back
Connect the Zeb-Revo to the data logger (white cable to white connector and Zeb-Revo, blue
cable to the blue connector)
Connect the camera by plugging in the mini USB cable in the port on the Zeb-Revo (it is
sensitive!)
Plug the data logger into the battery (short black adapter cable)
Switch on the data logger by pushing the button once and wait until it is blinking red.
Turn the head of the scanner once (>360°) then wait until it turns green (don’t move it!)

Data collection:






Switch on the camera by pressing the button on the top of the GoPro (once for immediate
recording, hold for power on but no recording)
Switch on the scanner by pressing the button on the side of the Zeb-Revo
Pick up the Zeb-Revo measure the area while avoiding moving objects and staying behind the
back panel
Finish recording by going back to the starting point and put the Zeb-Revo in the same starting
position.
The data will now be transferred from the Zeb-Revo to the data logger. Wait until the light on
the side of the Zeb-Revo is blinking red and then unplug the Zeb-Revo.
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The data will still be processing inside the data logger. Wait until the AUX light on the data
logger stops blinking orange and the Zeb-Revo light on the data logger is blinking red and then
remove the white and blue cable from the data logger.
Connect the external data export cable to the data logger (blue AUX connection) and to a USB
stick. Wait until the green AUX light on the data logger is gone and only the Zeb-Revo light on
the data logger is blinking red. This means the data has been transferred onto the USB stick.
Unplug the external data export cable and switch off the data logger by pushing the button once.
Disconnect the data logger from the battery (unplug the adapter cable)
Pack it back into the bag.

Data processing
1. Copy all the data from the USB and camera onto your local computer
2. Drag and drop the zip file (measured data) from the local computer and the matching camera
file (mp4).

3. Set what kind of output files you would like to get (las, laz, ply, etc.). It is also possible to
reduce the number of points randomly (max 50% recommended) and to define the attributes
of the extraction (colorized by time, SLAM condition or GoPro camera)

4. Then start the process with the process button.
5. After the processing is finished, save your data by clicking Save results. You can
immediately view your data by clicking on view or open in the final prompt.
If the resulting point clouds do not yield reliable results, there is unfortunately no way of changing
the outcome due to fact that the SLAM algorithm and software is a black box. Hence it is important
to be very precise in your measurements when using the older version of the Zeb-Revo.
5
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Real-Time Zeb-Revo
The real-time (RT) version of the Zeb-Revo uses a mini-computer for data collection that is instantly
processed and visualized. Due to the high computional requirements this over the shoulder computer is
ventilated and therefore much more susceptible to wet conditions. The RT Zeb-Revo should only be
used in dry conditions, for all other applications it is best to use the original Zeb-Revo. The process of
data collection and processing for the RT Zeb-Revo can be found in detail in the “ZEB-REVO RT User
Guide V1-0-2”. The following explanation is a short walkthrough of the steps necessary to successfully
collect and process data, including a list of the equipment available.

Measurement accessories














Flight-Case
Real-Time Data Logger
2 Lithium Ion batteries
Handheld scanner (Zeb-Revo)
Cable which connects the handheld scanner and camera to the data logger
Cable which connects the data logger to an external data storage
USB stick
Dongle (for the GeoSLAM software license)
USB mini cable (to connect GoPro camera to the computer + charging (white))
Charger/Adapter for battery for real-time data logger
GoPro camera attached to Zeb-Revo
Magnetic back attachment

In practice
Start-up and data collection:














Find a stable point where you can put the device on its back
Connect the Zeb-Revo to the real-time data logger (white cable to white connector and ZebRevo)
Connect the camera by plugging in the mini USB cable in the port on the Zeb-Revo (it is
sensitive!)
Turn on the real-time data logger
Connect your phone or tablet to the Zeb-Revo network:
o Wifi: geoslam-rt
o Password: zebedee12
Open a browser and go to http://192.168.102.2
Before starting a new scan start the GoPro by clicking the top button once
Once connection has been made, press new scan/start and enter a name for the dataset
Once the initializing is done, power on the Zeb-Revo with the side button on the handheld
scanner.
The scan has started and data can now be collected safely.
When done place the handheld scanner in the same location as the start point and click the end
scan/stop button.
After global optimization is done turn of the GoPro by clicking the top button once

While scanning the coloured dot in the top right of the screen will show the SLAM conditions. A red
dot will indicate poor slam conditions. This means during processing the scan data may come out
distorted or not process. An Orange dot will indicate satisfactory slam conditions. Data collected in this
region should process acceptably. A green dot indicates good slam conditions. Data collected in this
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region should process acceptably. Where possible scanning should be conducted in the orange and green
regions to ensure data processing.

Data Processing
Unlike the original scanner the RT Zeb-Revo has already processed all the data and is now available
for download or viewing on the GeoSLAM network. Download the. geoslam file and then drag it into
GeoSLAM Hub. The data can then be unpackaged and viewed and saved in different formats. When
using the “save results as…” option the data will be saved as. laz files. Other extensions and files that
are colored according to time, height etc, or less dense point clouds can be downloaded by using the
“more files” button. Other processing changes such as “Conservative Outlier Pruning” can be made
by clicking “…” and reprocessing the point cloud.

Processing data notes
For Zeb-Revo data focusing on forestry data or outside locations, it is best to set the number of points
to 100% and also check the “Large range filter slope” processing option. Although this option removes
some outliers in the point cloud it is unclear what the algorithm behind this feature specifically excludes,
due to the SLAM algorithm being a black box. Therefore, it might be more favorable to perform outlier
removal within other software that specifies what are the boundaries of the outliers. Some point clouds,
often ones with a low algorithm condition, fail to create a complete point cloud during processing with
the “Large range filter slope” option checked. In those cases use the default “.las” output that is created
during processing.
The merging tool available in GeoSLAM Hub does not offer many options in the alignment of different
point clouds and it is therefore advised to use the merging methods specified within the CloudCompare
section of the guide.
Lastly GeoSLAM Hub also offers the ability to combine the point cloud with the captured video footage
as is also explained in the “ZEB-REVO RT User Guide”. This ability allows for visualization of the
video footage along the trajectory of the Zeb-Revo recording. Furthermore, the point cloud can be
colored according to the video, this option is however still very unreliable and not very useful for
forestry or any classification attempts.

CloudCompare
The Zeb-Revo can collect roughly 20 minutes of data. This is often enough to retrieve a highly detailed
dataset of the study area. However, some areas might be bigger or more complex in structure and require
multiple Zeb-Revo scans. Considering the Zeb-Revo is only equipped with an inertial measuring unit
(IMU) there is no simple way to overlap these dataset using GPS coordinates. There are three possible
ways to merge these datasets, namely via spherical markers, merging via simple point pairs or automatic
merging. This section will go through the steps necessary to perform all three merging methods in
CloudCompare (CloudCompare v2.9.1, 2017). Furthermore, it will provide information on a few useful
tools for Zeb-Revo data.
When recording multiple datasets that have to be merged later it is useful to have the same starting point
so that the positioning of the point clouds becomes more clear. The merging of multiple point clouds is
a less precise method of merging due to it depending on the selection of x, y, z points that overlap in
the clouds in question. This method should therefore only be used if merging via spherical markers is
unavailable. Furthermore, the purpose of the dataset has to be considered when deciding how to merge
and if it is useful to merge. When using point clouds for precise measurements of for instance tree
structure parameters, the use of simple pair merging might decrease the reliability of these measurable
parameters and therefore be unfit. When using point clouds for classifications of objects the precise
measurements might be less important and simple pair merging could provide more reliable data.
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Visualization
Before merging can be done it is important to get familiar with a few visualization and navigation
options in CloudCompare.
Open CloudCompare
Go to File > Open, and open “TutorialCloud01.las”.
A window will appear concerning the characteristics and display of the point cloud.
Click Apply (default settings are correct)
To move the point cloud around use left click to rotate around the rotation center and use right click to
move the point cloud in its entirety. The point cloud will appear colored by recorded time.
There are a few basic changes that can be made to change the visualization:
1) On the left you can set the view of the point cloud

and change the rotation center

2) While zooming and rotating the automatic center can sometimes be in an unfavorable
location leading to difficulties in navigation. To make sure the rotation center is correct set the
“Set pivot visibility”

to always visible.

With the point cloud selected, under the Properties window:
3) Under Cloud, you can change the point size
4) Under Color Scale you can change the color and type of visualization
5) Under SF display params you can change the visible points depending on parameters (The
graph visible in SF display params can be examined further by using the show histogram
button in the top bar)
With the visualization of time it is possible to see which data points were recorded at what time, however
the path taken during the recording of TutorialCloud01 is not clear. The trajectory can also be added by
going to File > Open, and opening “TutorialCloudtraj01.ply”. Once again Apply the default settings.

Merging
Simple point pairs
Open TutorialCloud02.las
When loading both point clouds it becomes apparent that the initial start location overlaps but that any
movement hereafter (while recording with the Zeb-Revo) does not line up correctly seeing as these
point clouds should overlap for the most part. Merging these two clouds is difficult due to the fact that
overlapping points are hard to find by hand. However, this will be necessary if spherical markers do not
exist.
First it will be necessary to get TutorialCloud02 in roughly the right location compared to
TutorialCloud01. To do this click on “Set top view” on the left. TutorialCLoud02 should first be rotated
180 degrees on the z axis. Click on the “Translate/rotate”
button at the top. Then for “Rotation”
select the “Z” axis. Rotate the point cloud and drag it so that the start locations line up once more. If
you want to move the camera view point while using the translate/rotate tool use the “Pause” button.
See “MergingPositioning” video
TIP: Try to find bigger trees that are clearly visible in both point clouds to line up both datasets.
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Once the point clouds are roughly lined up simple pair merging can be done. During this process
TutorialCloud02 will be aligned to TutorialCloud02 which is the reference point cloud. First set the
view to “Set right sight view” with TutorialCloud02 on. Zoom in to the left of the point cloud so that
your screen resembles the left image in figure 1 (TutorialCloud02). The tree pointed out in this figure
shows a tree with a high density point cloud that is present in both datasets. This will be the first object
from which two points will be selected for merging.

Figure 1: Left: Image showing the first reference tree in TutorialCloud02 Right: Same tree in TutorialCloud01

Select both the TutorialCloud01 and TutorialCloud02 layers and click the “Align two clouds by
picking (at least 4) equivalent point pairs”
ordered as can be seen in figure 2.

button at the top. Make sure that the point clouds are

The alignment box will now be open and points can be selected in the aligned and reference point
clouds. With only the aligned point cloud turned on select a point at the base of the tree. Once selected
turn of the aligned cloud and turn on the reference cloud and select a point in the same location at the
base of the tree. Do the same for a location in the higher reaches of the tree. Continue to create reference
points throughout the point clouds.
TIP: Do not put two reference points to close to each other and try to spread out the reference points
along all axes.
TIP: When selecting a point make sure you did not select a point in front of it by checking the location
of the point in 360 degrees.
Points can be deleted when misplaced by clicking the
button next to that specific point. Once at least 3 reference
points have been selected it is possible to align the point
clouds. Make sure that before clicking on the “align”
Figure 2: Settings for cloud alignment
button the “adjust scale” and “auto update zoom” options
are unselected. When clicking align the point clouds will attempt to align with the smallest error
possible. Once the clouds are aligned with a small error click the
button to finish aligning the
clouds. The Console will show what the Final RMS error is. If the clouds do not seem to align correctly
or the Final RMS is too high, go through the same process and make sure to select reliable reference
points. A Final RMS below 0.25 is a good aim.
Now that the clouds have been aligned they can be merged into one cloud. Go to Edit > Merge and
click yes for “generate a scalar field with the original cloud index”. To save the final merged cloud go
to File > Save with the merged cloud selected and make sure that you are saving the file as a “.las”.
See “MergingSimplePair” video
9
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Spherical markers
A quicker and often more reliable way to merge point clouds is the use of
spherical markers. These markers can be any spherical object as long as they are
located in a fixed place during the collection of both datasets. This guide uses
basketballs to show the possibility of using spherical markers for merging (Fig
3). The data used in this part of the guide is not particularly reliable but can still
be used to show the potential of marker merging. Two spherical markers were
used whereas datasets should normally include at least three markers for a
reliable alignment.
Go to File > Open, and open both TutorialCloud03 and TutorialCloud04. Unlike
the clouds used in simple pair merging these clouds have been colored according
to their height for a clearer visualization.

Figure 3: Basketball
used as spherical
marker.

Change the view to “Set top view” and rotate TutorialCloud04 so it roughly aligns with
TutorialCloud03.
See “SphericalMarkerPositioning” Video
With the clouds aligned it is now possible to locate the spherical markers. As can be seen in figure 4
on marker is out in the open on the right and the other marker is located underneath the canopy on the
right.

Figure 4: Top view of TutorialCloud03 and TuroialCloud04 roughly aligned with the markers location marked
in red.

Once the spherical markers have been located zoom in on either one so it is clearly visible in both point
clouds.
TIP: For better visualization of the spherical markers it might be useful to increase the point size of
both clouds to 2.
Click the “Align two clouds by picking (at least 4) equivalent point pairs” button with both clouds
selected. Make sure that the TutorialCloud04 is the aligned cloud and TutorialCloud03 is the reference
cloud and press Apply. Click the “Pick spheres instead of points (for clouds only)”
button and
select the sphere in the aligned cloud first. Most likely an error will occur that says one of the following:
1. RMS is too high!
2. Failed to crop points around the picked point?!
3. Detected sphere radius (x) is too far from search radius!
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(1) If the RMS is too high (10%) then the value needs to be change to a higher value so that the
boundaries of the detection will be lower (25%). This can occur for the left sphere in TutorialCloud04
due to the spherical marker having a distorted point cloud. (2) If CloudCompare failed to crop points it
might be that either the wrong point was selected or that there are not enough points in the spherical
marker cluster to recognize a sphere. (3) If the detected sphere radius is to far the it is necessary to either
increase or decrease the r value in the top right of the referencing window. In this case it will most likely
be to big seeing as the spherical markers are quite small. The r value specifies the radius in which the
tool searches for a spherical object. Furthermore, the r value is an implicit unit which means it is
expressed in the same units as the data loaded into CloudCompare. A value of approximately 0.2 will
yield a spherical recognition for TutorialCloud04.
TIP: Always try to create spherical markers with a high RMS limit if possible to increase the reliability
of the alignment.
See “SphericalMarkerSelection01” video
Do the same for the second spherical marker and select a third simple point marker. Watch the video
mentioned below if you are having difficulties locating the second spherical marker.
See “SphericalMarkerSelection02” video
When both spherical markers have been turned into reference points and a third point has been selected
click Align. The Final RMS value should be around 0.15. With more reliable point clouds and multiple
spherical markers this Final RMS can be decreased even further. The aligned clouds can then once more
be merged via Edit > Merge.
See “SphericalMarkerAlign” video

Automatic alignment
Another method to merge clouds is to use the automatic alignment
feature of CloudCompare. This tool aligns already roughly aligned
point clouds. This is however a more difficult tool to use for forested
areas considering the amount of spatial variability in both point clouds.
Furthermore, considering the point clouds used in the last two merging
methods do not completely overlap, this tool cannot be applied seeing
as it tries to overlap/align the entire point clouds. Moreover, these point
clouds contain 9 to 14 million points which leads to a very high
computational time. This tool can provide a higher reliability in
merging with a lower RMS if the point clouds in question are suitable.
Therefore, before this method will be explained a specific tree will be
extracted from both datasets.
CloudCompare provides a simple tool to create cross sections of point
clouds and extract these sections. First, Open both TutorialCloud01 and
TutorialCloud02 and rotate TutorialCloud02 180 degrees once more so
that the datasets are roughly aligned. Now focus the view again as
specified in figure 1. With the cross section tool, you will extract the Figure 5: Extracted tree from both
point clouds using the cross
tree pointed out in figure 1 in both point clouds. Select TutorialCloud01
section tool.

and click the cross section
button. Use the arrows on the sides of
the box to decrease the size of the point cloud until only the specified tree is left. To extract this tree as
an independent point cloud click the “Export selection as a new cloud”
button. Do the same for
TutorialCloud02 so that you are left with two points clouds of a single tree as can be seen in figure 5.
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See “CrossSection” Video
Now that only this single tree is left use the “Translate/rotate” button again to align both point clouds
of the tree. Once they are aligned click the “Finely registers already (roughly) aligned entities
(clouds or meshes)”
button. In the Cloud registration window settings can be left at default values.
If the point clouds have more than 50000 (default) points a higher accuracy can be achieved by
increasing the Random sampling limit under the Research tab. Click OK. The aligned point clouds
should have a much lower Final RMS than the RMS value seen in simple point pair merging. A good
aim is a RMS value below 0.025. The aligned clouds can then once more be merged via Edit > Merge.
This method could also be applied after using simple point pair merging to increase the reliability of
the already aligned point cloud. However, this is once again dependent on the amount of overlap of the
two point clouds.

Additional CloudCompare tools
There are many more possibilities in CloudCompare,
the following is a short overview of a few possibly
useful tools for scientific application.
CloudCompare has the ability to display the density
of a point cloud based on a certain defined radius.
This can show where a dataset is the densest and can
give an indication of which areas of the point cloud
are most reliable. Furthermore, it can provide a
histogram of the volume density distribution for a
specific radius. To do this go to Tools > Other >
Density with the point cloud in question selected.
For a histogram click the show histogram button at
the top. The higher the precise radius the longer the
computational time. An example of a point cloud
(TutorialCloud05) colored by density and its related
histogram can be seen in figure 6.
In some cases, a high point cloud density could lead Figure 6: Top: Point cloud colored by density with a
radius of 0.5, Bottom: Histogram of the point
to high computational times. Furthemore the goal of
density.
certain analyses might not be dependent on a high
point cloud density. Decreasing the density of the point cloud can therefore be favorable considering
the computational time. This can be done in GeoSLAM Hub but is much more reliable in
CloudCompare considering the control over the methods of subsampling CloudCompare provides, such
as min. space between points. To use this tool click the “subsampling”

button at the top.

Lastly sometimes it’s useful to calculate the distance between two points. To do this click the “Point
picking”

button at the top and then select

.
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LAStools
LAStools can be used for many different things concerning point clouds such as, extension conversion,
clipping, ground point extraction and classification (Isenburg, 2014). This part of the tutorial will focus
on the capabilities of LAStools in extracting ground points from Zeb-Revo point cloud data and the
different parameters this is dependent on.
Open the “lasground_new” application in the bin folder of LAStools. Browse to the tutorial folder and
select “TutorialCloud05.las”. There are some default settings on the right such as wilderness, nature
and town or flats. These settings and LAStools are aimed more on aerial laser scanning (ALS) data and
parameter values are therefore somewhat large for Zeb-Revo data. However, lasground_new can still
classify ground points reliably by changing the custom settings.
There are five settings namely the step, bulge, down spike, spike and offset.






Step = Changes step size of las analysis (min = 1)
Bulge = The bulge affects how the triangle that the point under consideration falls into is
interpolated at this points x/y coordinate to compute its z_int. A bulge of zero means that the
facet is planar and z_int lies "in the triangle". A bulge of non-zero means that the three
normals of the triangles are used to "bulge" the triangle either up or down (depending on the
normal direction) so that z_int can lie "above" or "below" the triangle.
(Down) Spike = Spike defines the threshold of ground classification.
Offset = The offset decides how high the real z of the considered point is allowed to lie above
the interpolated z_int to be considered a ground point, namely no more than the offset. For an
offset of zero, the real z of the considered point must be equal or lower than the interpolated
z_int to become part of the ground. For an offset of 0.05, the real z of the considered point is
allowed to lie up to 5 cm above the interpolated z_int to become part of the ground.

To create a ground point classification of the TutorialCloud05 las tile, it is important to understand the
parameters mentioned above and set them to the right level for a reliable return. For this dataset values
should be set as follows:
-

Step
Bulge
Spike
Down Spike
Offset

=1
= 0.2
= 0.07
=1
= 0.02

To save the output select the correct directory and choose a filename at the top right,
also change the output extension at the right bottom to las. Check “compute height”
for easier further classification. Do not check “replace z” because it will move higher
elevated z values to the average z point value. For areas with steeper elevation it could
prove useful to intensify the search for initial ground points by setting it to fine, extra fine etc.
Click RUN to classify the ground points. Use either ArcScene or CloudCompare to visualise the new
point cloud (Ground01).
To extract the ground points from the new point cloud, use the “lassplit” application in the bin folder
of LAStools. This application can split point clouds based on their classification. Select the
“Ground01.las” file under browse. Then select by classification on the right side and once again choose
a directory, filename (Split01) and las extension for your new point cloud. Click RUN. LAStools will
automatically name your split point clouds (Split01_0000001, Split01_0000002). Split01_0000002
contains the extracted ground points which can be used later when classifying trees or creating a DEM.
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3D Forest
There are many applications that can be used to segment, analyze and classify forestry point cloud data.
3D Forest is an open source program that has the capability of automatically segmenting vegetation
using two point clouds, namely a terrain and vegetation point cloud (Trochta et al., 2017). In the last
section both these point clouds were created (Split01_0000001, Split01_0000002). These point clouds
will be used as example within 3D forets to shortly display the automatic segmentation of the software.
However, the resulting segmentation is very unreliable because the vegetation point cloud includes a
lot of outlying points and ground points. Due to the fact that 3D forest has limited option concerning
data processing and analyses this guide will not elaborate further then the basic principle of 3D forest.
Other applications might be able to rely more on the possibilities within 3D forest.
Start 3D Forest and go to Project > New Project. Select a name and location for your project. For
“Choose transform matrix” choose “NO_MATRIX”. Click Next and Finish. If a prompt appears, click
Yes.
Go to Project > Import > Import Terrain Cloud, and select Split01_0000002.
Go to Project > Import > Import Vegetation Cloud, and select Split01_0000001.
Once the data has loaded go to Vegetation > Automatic Tree Segmentation.
In the “Automatic segmentation” window make sure that Split01_0000001 is the vegetation cloud and
Split01_0000002 is the terrain cloud. Leave the input distance at default but change the “minimal points
in cluster” to 400 and click Okay. This yields 35 new segmented point clouds. When turning of the
original and vegetation-rest layer it becomes clear that the presence of ground points has made the
classification somewhat incorrect. However, when unselecting these ground points, the resulting
selection shows a quick visualization of the biggest trees in this dataset (Fig 7). The reliability can be
increased by first using the outlier removal option, 3D forest offers minimal noise removal options
compared to other software such as CompuTree. Furthermore, no adjustments, such as size, can be
made to the automatic tree segmentation of 3D Forest. 3D forest might provide more possibilities in
tree structure parameter extraction, such as diameter breast height and crown delineation, which should
be further explored.

Figure 7: Image displaying the tree segmentation capability of 3D Forest, with a
visualisation of the layers that are turned on.
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CompuTree
Another open source program that can segment, analyze and classify forestry point cloud data is
CompuTree (Othmani et al., 2011). This section will give a step by step walkthrough of a some of the
tools that can be used to create tree inventory data based on a Zeb-Revo point cloud. Each step is
numbered according to the amount of steps present in the eventual workflow.

Initialization
1. Loading and visualization
Open CompuTree, go to Window > Steps (F2) to open the steps window which will be used to access
the necessary tools. Click on Load > Points > Points, format LAS and select TutorialCloud05. The
first step should now be visible in the steps workflow on the right. To load and visualize the dataset
right click the step and click on Execute
. Once CompuTree is done loading the point cloud, check
the Results box so that the results show up in the “Model manager” window. Check the box next to
Scene to visualize TutorialCloud05.
CompuTree also includes a few basic coloring capabilities. To change the colour of a specific layer in
the “Model manager” right click the layer and then choose one of the available coloring options. A
clear visualisation for this layer would be Colorize points of each element by > 1 > Z, which shows
the height from red to yellow.
NOTE: CompuTree is open source software that is not entirely stable, this can lead to issue with
colorization changing when turning layers on and off. Furthermore, high computational steps could lead
to the program overloading and crashing without any displayed error. To avoid loss of data or steps be
sure to save your workflow regularly via File > Save the steps tree. Most commonly after the crash the
program will load the most recent version of your steps workflow.
Next it is important to classify the ground points. As shown during the LAStools section this can be
done using the lasground_new application. However, the method in which ground points are selected
in CompuTree is different than the method provided in LAStools. CompuTree uses a ground point
selection based on the “Minimum density” of a point cloud (cluster), “Ground thickness” and
neighbouring points in a specific point cluster. Furthermore, one of the shortcomings of LAStools is
that it is mainly designed for large scale/highly spatial data, which means it can only select ground
points in grids of 1 meter. CompuTree provides a higher detail selection that can create a grid selection
of ground points up to 1 cm. However, depending on the aim of the study or data analyses either
software could provide beneficial features. For forestry data the use of CompuTree is advised.

2. Ground point classification
In the Steps menu got to Points > Classify > Classify
ground points. In the “Configuration” window leave the
values at default settings (Fig. 8). For a more precise
classification the “Grid resolution” can be decrease to for
instance 10 cm. For areas with a very steep or diverse
ground profile it is also advised to decrease the “Grid
Figure 8: Default settings for the
classification of ground points
resolution”. So that the effect of height differences on the
classification of ground points is diminished. Keep in mind that a smaller grid resolution means a longer
computational time. For point clouds of relatively flat areas with little ground disturbance, “Ground
thickness” can be decreased as well. Considering Zeb-Revo contains highly dense data the choice can
also be made to increase the “Minimum density”. However, for the purpose of this tutorial default
settings will yield satisfactory results while keeping the computational time to a minimum. Click Apply.
The result can once more be visualized by checking the Results box and turning on the Ground points
layer. The classification tool also yields a rasterized version of the point cloud which can be found in
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the Classification raster. This result also automatically contains a ground point density layer which
can be useful to determine the reliability of the dataset.
NOTE: To change values within any of the already established steps in the workflow, right click on
the step and click on Config. parameters
documentation

. For a more detailed description of the step click on Step

.

The Zeb-Revo contains some erroneous data in the form of floating points above or next to objects and
also above the ground. Furthermore, the classified ground points currently include objects such as fallen
tree logs and the start of tree trunks. These points and other noise should, of course, not be part of the
ground point data and should be removed to create a cleaner ground point dataset.

3. Ground point noise removal
In the Steps menu got to Points > Filter > Removes noise from detected ground points. A window
will come up which asked for the input data. Select Results_ONF_StepClassifyGround and make sure
that Ground points is selected in the input data selection. Click OK. The noise removal will show in
which a value can be set for the angle of deviating points that need to be removed can be set. Considering
most tree trunk albeit fallen or upright do not start at an angle of 45 degrees the value should be
decreased to at least 40 Degrees.
NOTE: Always be sure to check that you have the correct input layer selected which is the results of
the step prior. Furthermore, after each step don’t forget to execute the step in the steps workflow and
visualise the data so that you can be certain that the results are correct.
Although ground points have already been classified, to further classify the point clouds displaying the
vegetation it will be necessary to create a DTM based on these ground points.

4. DTM
In the Steps menu got to Raster/Images > Digital elevation models > Create DTM (simplet…) and
set the Raster resolution to 0.50 m. Once again the raster resolution can be decreased for a more
detailed DTM. However, this is not necessary for the purpose of examining forest structures and will
increase he computational time immensely. For studies focussing on elevation changes or anything
reated to the DTM the choice can also be made to use another tool namely: Raster/Images > Digital
elevation models > Create DTM (onf). This tool also allows for changes to the amount of smoothing
and the size of the interpolation.
Now that the ground points have been classified, cleaned up and transformed into a DTM it is possible
to start cleaning the vegetation point cloud and segmenting individual trees. To do this the vegetation
will be divided into two point clouds based on height compared to the DTM, so that different methods
of noise removal can be applied on the lower ranges and higher ranges of the vegetation.

Lower vegetation slice
5. Extraction
In the Steps menu got to Points > Extract > Smooth extraction of a point slice parallel to the DTM
and select the Vegetation points [Point scene] under Scene > Results and the DTM_ST
[Raster<float>] under MNT (Raster) > Results. Click OK and in the next window set the H minimum
to 0.30 m and the H maximum to 2.30 m. Depending on the height of the vegetation and the structural
characteristics of the trees that are meant to be classified, this value can be changed. For example, to
eventually only be left with larger tree trunks that are straight and perpendicular to the DTM and have
little branches in the lower ranges (conifers), the H maximum can be increased.
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6. Noise removal
In the Steps menu got to Points > Filter > Removes noise from the stem slice and select both Slice
above DTM [Point scene] and Denoised ground points [Point scene] under Results_In > Results
ST_StepExtactSliceAboveDTM. Before continuing change the searched data behind Denoised
ground points [Point scene] to Ground cloud. Click OK and in the next window leave the angle at
the default value (45 Degrees). This will remove point clusters that do not have perpendicular
directionality compared to the DTM.

7. Euclidian clustering denoising
The current Denoised Stem Slice still contains a lot of point clusters that are not part of any tree or
clear vegetation and can thus be considered noise. To remove these clusters, it will be necessary to use
Euclidian clustering denoising which divides the cloud into the smallest clusters (noise) and the largest
clusters (trees/vegetation).
In the Steps menu got to Points > Filter > Euclidian clustering denoising and select Denoised stem
slice under Results_In > Results ST_StepFilterStems. Consideirng we are looking to eventually
segment and extract larger trees the clustering distance should be increased to 0.10 clusterTolerance
m. For research aiming to analyse smaller objects which can be closer to each other the cluster distance
can be left at the default value or further decreased. The number of clusters should not be a limiting
factor and should therefore be increased to a safe margin of 1000 numCluster. The number of points
a cluster needs to contain can be left at the default value of 1 due to the fact that cluster size will be
defined in the next parameter. If clear information is available on the amount of points for each tree this
value could be changed to the value of the smallest tree cluster. The number of points a cluster needs
to contain in percentage of total size should be set to 0.2 min percentage to secure that the largest
clusters (mostly trees) will be left. Make sure the parameters are set correctly as can be seen in figure 9
before clicking Apply.

Figure 9: Settings for Euclidian clustering denoising that yields reliable results.

NOTE: While adding different step of denoising and point cloud extraction don’t be afraid to change
the values to see how each tool works and to create a cleaner and more reliable dataset. Trial and error!

Upper vegetation slice
The same process will be applied to the higher ranges of the vegetation but without the use of the
removes noise from stem slice tool. This is due to the fact that any smaller branches in the higher
ranges of the vegetation must be left in. Using this tool could remove important data cluster concerning
the structure of the trees.

8,9. Extraction and Euclidian clustering denoising
In the Steps menu got to Points > Extract > Smooth extraction of a point slice parallel to the DTM
and select the Vegetation points [Point scene] under Scene > Results and the DTM_ST
[Raster<float>] under MNT (Raster) > Results (ST_StepComputeDTM). Click OK and in the next
window set the H minimum to 2.30 m and the H maximum to 50 m. For the upper slice always make
sure it continues where the lower slice ends and it has a maximum value that exceeds the range of the
maximum z value of the point cloud. For the Euclidian clustering denoising set all values as displayed
in figure 9.
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Segmentation
10. Merging vegetation
Before segmentation can be performed it is first necessary to merge the lower and upper ranges of the
vegetation again. In the Steps menu got to Points > Clusterize > Merges multiple clouds and select
both
Largest_Clusters
[Point
scene]
layers
under
Results_in
>
Result
ST_StepExtractLargestCluster. Click OK and the clouds will be merged yielding a single vegetation
layer.

11, 12. Marker slice and sub clouds
To segment each individual into an independent point cloud it is first necessary to create a marker for
each tree by creating a small slice above the DTM from the new merged vegetation data. This marker
can then be aligned with the rest of the point cloud cluster it is attached. This secures that trees that
might come in contact in the upper ranges of the vegetation are not clustered into the same segment
when applying individual tree segmentation.
In the Steps menu got to Points > Extract > Smooth extraction of a point slice parallel to the DTM
and select the Merged_Cloud [Point scene] under Scene > Results and the DTM_ST [Raster<float>]
under MNT (Raster) > Results. Click OK and in the next window set the H minimum to 0.20 m and
the H maximum to 0.5 m.
Now to add the rest of the point clouds from each tree to the cluster clouds go to Points > Extract >
An Euclidean clustering operation. Produces sub clouds of the clusters. and select (the
lowest/latest) Slice above DTM [Point scene] and click OK. For this Euclidean clustering keep the
settings at default values and click Apply.

13. Segmentation into tree clouds
If the steps prior were executed correctly a new segmentation tool should now be available. In the Steps
menu got to Points > Clusterize > Segmentation into tree clouds and select the Clusters [Point scene]
and Merged_Cloud [Point scene] under cloud_in > Results and click OK. In the next configuration
window leave the settings at default values. In case you have a computer with a fast CPU (16gb RAM,
quad-core) you can increase the Speed of computation to 5. If you are working with a slower CPU or
this step takes too long to compute or CompuTree crashes while trying to complete this step, decrease
the Speed of computation. Click Apply.
Once executed the resulting Isolated Tree layer can be best visualized by right clicking and changing
the color to Automatic color > 1. This way each tree is visualized with a separate color resulting in a
Point cloud as can be seen in figure 10.

Figure 10: Left: TutorialCloud05 before CompuTree processing, Right: TutorialCloud05 after CompuTree processing
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Lastly during these steps and after the segmentation it is possible to apply multiple Statistical Outlier
Filters. To do this go to Points > Filter > Statistical Outlier Filter and select which ever layer you
want to apply the statistical outlier filter to. Values for this filter depend on the intent of the filter and
the point cloud you are executing it on. A quick walkthrough of the steps describe in this CompuTree
guide can be found in the movie mentioned below.
See “CompuTreeAnalysis” video

Installation/Download links
The following links directly forward you to the installation site for all software used in this guide,
excluding GeoSLAM Hub.
CloudCompare
LAStools
3D Forest
CompuTree
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